Introduction to the OpenSim GUI
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Navigating the OpenSim GUI

Launch OpenSim
From File menu, select Close Model to close any existing models
From File menu, select Open Model

Navigate to folder HandsOnMaterial> Introduction, select
gait2392.0sim
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Using the View window

ROTATE: left mouse button, drag mouse

TRANSLATE:  middle mouse button, drag mouse

ZOOM: right mouse button, drag mouse

File Edit Scripts Tools Window Help
Time
Simulate Motion: [static pose
Ii/ W Speed 1 Ml <« 1>l

 Navigator @ % ; Coordinates
@-() oait2392_Pic_generic

way, ABojoda,

orienting icons

 gait2392_PiG_generic - Properties

S properties a
name ait2392_PiG_gsneric

type Model

credits Delp S.L., Loan J.P., Hoy M.G., Z... I
publications Delp, 5.L., Loan, J.P., Hoy, M.G.

length_units. meters

force_units N

gravity (0 -5.80865 0)

BodySet ()| [: seriptingsheii window Messages (X
ConstrainiSet ()1 Loaged model gaitz392_pic_genenc from fle 21\bropbox NMBL\GCMASTUtora 20 2P PGosm  ~
Forceset (2] | |No external lacs willbe appled (extemal loads fie not specified)

MarkerSet u Executing the analyses from 0 to 99...

T p—— ()~ |No extemal loads wil be appied (externaloads fle ot speciie).

Executing the analyses from 0 to 99,
Loaded model gait2332_PiG_pfContracture from file Z:\Dropbox|NMEL \GCMASTutorial2015\TutorialFies\gait2392_CP_PiG,
No external loads will be applied (external loads file not specified).
Executing the analvses from 0 to 99..,

<

ait2392_PiG_generic 7
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What is an OpenSim model?

OSIM files specify:

e Bodies

 Joints

* (Constraints

* (Contact Geometry
* Forces
 Markers
 Controllers

* Probes

 Other Components
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Navigator window shows model components

[ — I — — — - e —— = |
¢ OpensSim 3.2 o e S
File Edit Scripts Tools Window Help

= — Time |0.114 v L]
b{'j Simulate ‘ _#' - Motion: normalWalk_PiG e
el Speed 115 0.000 4l < Il > Il 1.000
an i Coordinates Viewd EI[E3] =]
N
1
-

Joints
oo Constraints
Contact Geometry
Forces
»" Markers
oo Controllers

§ Probes
O Other Components
Motions

|

: Bodies - Properties

groups
Il |objects
type




A few details ...

Each BODY:

* isassumed to berigid
* hasan associated reference frame
* often has mass, inertial properties

* often has associated visual objects

Files:

OpenSim 3.3 -> Geometry
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Properties window for bodies

3 OpenSim 3.2
File Edit Scripts Tools Window Help

Simulate ‘ .g’*

: Navigator 4l # |: Coordinates Viewd =2
=-() gait2392_PiG_generic »
2% Bodies

+- (g ground
- pelvis

Motion: Mo Motions

thaly Abajoda |

m

talus
; calen_|
- toes_|
+$ Joints
oo Constraints
- “% Contact Geol
#- 5% Forces
i Markers
. Controllers

eeeeeeeeede

+- M@ Probes

ﬁelvis - Properties

—| Properties

name pelvis

type By

mass 11.777
mass_center (-0.0707 0 0)
inertia_xx 0.1028
RErtia_yy 0.0871
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A few more details ...

JOINTS:
* connect adjacent BODIES

e constrain movements within
physiological bounds

* translations, rotations are coordinates
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Coordinates window shows model coordinates

- . ‘ % - 23
File Edit Window Help
) - Time |0.114 a8 [
Motion: normalWalk_PiG =
Speed 1% 0.000 Il « 11 b Ui 1.000
: Navigator | Coordinates < 2= | ViewD = AlHx 15

Model: 3DGaitModel239  Pases > |
Mame Value Speed it
pelvis_tilt -1.383 | Im ¢ an @ a0 0.000
pelvis_list -3.675 | s ag @ an 0.000

pelvis_rotation 1.682 | s an a a0 0,000
pelvis_tx 0,000 | “la 5 @ 5 0.000
pelvis_ty 0,960 | “la 1 @ 7 0.000
pelvis_tz 0.000 | “ba ¢ 3 @ 3 0.000

hip_flexion_r 20,733 | -1 @ i7p |0.000
hip_adduction_r 5236 | W -1 @ 120 |0.000

hip_rotation_r 4196 | W -120 @ 120 |0.000

knee_angle r | -15.826 |l § -120 @ 10 0.000 =

ankle_angle_r -1.364 | s an @ a0 0.000

subtalar_angle_r 0,000 “ha an a a0 0,000
mtp_anale_r 0,000 | “la an @ 90 0.000
hip_flexion_| 5270 ‘WM -120 @ 120 |0.000
hip_adduction_| 3322 |'M e 120 @ 170 |0.000
hip_rotation_| 0.766 |l T -120 @ i2p |0.000
knee_angle || -37.382 |l = -120 @ 10 0.000
ankle_angle_| | -12.205 Ta 0y @ &0 0.000
subtalar_angle_| 0.000 | “ba £ -ap @ Ty 0.000
mtp_angle_| 0.000 | “ba oy @ &0 0.000
lumbar _extension 1.383 | s a0 @ Ty 0.000
lumbar_bending 3.676 = -an & an 10,000 -




More details ... {,{»{’i
MUSCLES: %\\\
* transmit force at attachment sites on bodies 2 \
: Sy \
* may “wrap” over underlying surfaces L N
* forces depend on activation, length and velocity
Force-Length Force-Velocity

Curve Curve

1 V o
Muscle Length Muscle Velocity
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Properties window for muscles

3 OpenSim 3.2

File Edit Scripts Tools Window Help

Simulate ‘ .g"

Motion: |Mo Motions

: Navigator 4l % |: Coordinates Viewd & |t EJ @ =
=(0) gait2392_PiG_generic §_
+- % Bodies 2
38 Joints 3

e Constraints
~“% Contact Geometry

--“% Forces
—‘f_,- Muscles
5l
glut_med1_r
glut_med2_r
glut_med3_r
glut_min1_r
glut_min2_r
glut min3 r

semimem_r

semimem_r - Propertie

- Properties

name Femimem_t

type Thelen2003Muscle

izDisabled

min_centrol 0.0

max_control L0

GeometryPath

max_isometric_force 1288.0 ! ScriptingShell Window : Messages -

optimal_fiber_length 0.08 Loaded model CP2392 from file Z:Drophox WMEL \GCMASTutarial20 15 TutorialFiles\gait2292_CP_PiG. osim

tendon_slack_length 0.359 Loaded model CP2392 from file Z:\Dropbox\MMBL\GCMASTutorial 20 15 TutorialFiles\gait2392_CP_PiG.osim

pennation_angle_at_optimal 0.26179339 Loaded model gait2392_PiG_generic from file Z:\Dropbox \NMBL\GCMASTutorial 20 15\ TutorialFiles\gait2392_CP_PiG.osim
| Eax_cuntractiun_v&lucity 10.0 / =
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Loading a motion

* From File menu, select Close Model to close any existing

models
* From File menu, select Open Model

 Navigate to folder HandsOnMaterial\
Introduction\example_synchronization

* select subjecto1.osim

* From File menu, select Load Motion

 Navigate to folder HandsOnMaterial\
Introduction\example_synchronization

* Opensubjectox_walka_ik.mot

T

OpenSim

[ Model File

OpenSim
Motion File
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Animating a model

motion slider &
name of active motion playback buttons

E=RTE X

() OpenSim 3.2

File Edit Scripts Tools Window Help

Simulate ‘ #'

‘ Navigator a = } Coordinates
=-(0) 3DGaitModel2392
+- %’ Bodies
i35 Joints
o Constraints

Motion: normalWalk_PiG

4l 4 Il & lI>>

<% Contact Geometry
+-56 Forces

+- 5" Markers
o= Controllers
+- iy Probes
() Other Components S n a p S h ot ﬁ
-} 4~ Motions
= R :
¥

: normal_gait - Properties
name
type




On your own: Exploring the GUI

= Save afew snapshots at key events in the gait cycle.

» Use the View, Navigator, and Coordinates Windows to
answer the following questions:

1. How many bodies (segments) does this model have?
2. How many coordinates does this model have?

3. Whatis the maximum isometric force that the model’s
semimembranosus can produce?

4. How many muscle-tendon compartments are used to represent the
geometry of gluteus maximus and gluteus medius?

Why do you think these muscles are modeled this way?
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Demo of Model editing

<?xml version="1.0" encoding="UTF-8" 2>
(H<OpenSimDocument Version="20303">

W N

B <Model name="3DGaitModel2392">
4 © <!--8ee the credits section below for inf-:
7 ® <credits> Delp S.L., Loan J.P., Hoy M.G.,
21 <publications>

<length_units>meters</length_units>
<force_units>N</force_units>

29 <!--Acceleration due to gravity.-->
<gravity> 0 -9.80665 0</gravity>
31 <!--Bodies in the model.-->
3] <BodySet>
<!--Constraints in the model.-->
&) <ConstraintSet>
<!--Forces in the model.-->
®= <ForceSet>
<!--Markers in the model.-->
E3] <MarkerSet>
<!--ContactGeometries in the model.--
= <ContactGeometrySet>
in the model.-->
= <ControllerSet name="Controllers">
3670 <!--Probes in the model.-->
1 B <ProbeSet>
1675 <!--Additional components in the model
3676 + <ComponentSet name="MiscComponents">
36 - </Model>

w m
- O

o0

L</OpenSimDocument>
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Under the hood: OpenSim models

modelName.osim

<Model name=“Arm26">
<!—Default values for properties that are not specified.-->
<defaults> ...
<credits> Model authors names..
<publications> ...
<length units> m </length units>
<force units> N </force units>
<!--Acceleration due to gravity.-->
<gravity> 0.00000000 -9.80650000 0.00000000 </gravity>
<!--Bodies in the model.-->
<BodySet name=""> ...
<!--Constraints in the model.-->
<ConstraintSet name=""> ...
<!—All the force elements in the model.-->
<ForceSet name="">
<!—Kinematic markers on the model.-->
<MarkerSet name=""> ...
<!=—Surface meshes used by contact force elements in the model.-->
<ContactGeometrySet name="">

</Model>
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Viewing model files in Notepad++

Minimize OpenSim (click minimize button, upper right corner)
* Launch Notepad++

* From File menu, select Open ...

+ Navigate to folder HandsOnMaterial>Introduction

* Open gait2392.0sim
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Tip #1

If NOT color-coded:

from Language menu, select XML
S T e — gegem—)

File Edit Search View Enceding Language Settings Macro Run  Plugins  Window 7 X
cHHE LAl s ak| 2t < |BREIS1 FOIEDICEDEE|EY

= gait2392_PiG osim |
<?xml version="1.0" encoding="UTF-&" ?>
<CpenSimDocument Version="30000">
E <Model name="gait2392 PiG generic">
<credits>Delp S5.L., Loan J.F., Hoy M.G., Zajag F.E., Topp E.L., Rosen J.M., Thelen D.G., Anderson F.C., Seth A. Notes: 3D, 23 DOF gait model
<publications>Dglp, S5.L., Loan, J.P., Hoy, M.G., Zajag, F.E., Topp E.L., Rosen, J.M.: An interactive graphics-based model of the lower extre
<length_unit5>meters<flength_unit5>

»

B T Y S P SR

<force_units>N</force_units>
<!—-Acceleration due to gravity.—-->»
<gravity> 0 -9.80665 0</gravity>
<!--Bodies in the model.-->

g
1]

11 = <BodySet> =
= <objects>
1 [+ <Body name="ground">
61 = <Body name="pelvis">
62 <mass>11.777</mass>
63 <mass_center> -0.0707 0 D</mass_center>
64 <inertia_ xx>0.1028</inertia_xx>
65 <inertia yy>0.0871</inertia yy>
66 <inertia zz>0.0579</inertia zz>
a7 <inertia_xy>0</inertia xy>
68 <inertia xz>0</inertia xz> —
] <inertia yz»0</inertia_yz>
T0 <!-—Joint that connects this body with the parent body.-->
<Joint>

<CustomJoint name="ground pelvis">

27 </Joint>

278 <VisibleCbject>
342 <WrapCbjectSet>
348 </Body>

34T <Body name="femur r">
ST <Body name="tibia r">

<Body name="taluns r">

<Body name="calcn r">

<Body name="toes r">

<Body name="femur 1"> -
i | b
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Tip #2

From View menu, select Fold All

tutorial\Apoorva's TutorialFiles\gait2392_PiG.osim - Notepad++

File Ed Encodirm Language Settings Macro Run  Plugins  Window 7 X
Ao =1 EQED @EDEE|IEs v
& gat2392_ PG osim Toggle Full Screen Mode F11
El Pry— Post-It F12 n
2 Show Symbol 3 l—l
3
Z 3
4 eom lajag F.E., Topp E.L., Rosen J.M., Thelen D.G., Anderson F.C., Seth A. Notes: 3D, 23 DOF gait model
3 Move/Clone Current Docurnent * | M.G., Zajag, F.E., Topp E.L., Rosen, J.M.: An interactive graphics-based model of the lower extrem
6 Tab 3
7 Word wrap
; Focus on Ancther View F8
10 Alt+H
- Fold All Alt+0
12
- Alt+Shift+0
61 Collapse Current Level Ctrl+Alt+F
347 Uncollapse Current Level Ctrl+Alt+Shift+F
547 Collapse Level 3
548
Uncollapse Level 3
ST = _center>
550 Summary...
551
552 Project 3
= Document Map
554 Function List
I
CoG Synchronize Vertical Scrolling ody with the parent body.-->
557 E Synchronize Horizontal Scrolling
558 =
559 Text Direction RTL Ctrl+Alt+R body to which this joint connects its owner body.-->
560 Text Direction LTR Ctrl+Alt+L parent_body>
561 ZT--LOCation Of LHE joint in the parent body specified in the parent reference frame. Default is (0,0,0).-->
562 <location_in parenc>0 -0.404 [J<,-"location_in_parent>
563 <!-——0rientation of the joint in the parent body specified in the parent reference frame. Euler XYZ body-fixed rotation an
564 <orientation_in parent>0 0 U<,-"orientation_in_parent>
565 <!—-Location of the joint in the child body specified in the child reference frame. For 5IMM models, this vector is alway
566 <location>0.0045 -0.0082 0</location -
< T 3
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Tip #2

From View menu, select Fold All

e —
[ chserasamoldDesiop\ GEMES utorishApoona' Tutorialies\gait2392 PiG osm - Notepad=— ""”

File Edit Search View Encoding Language Settings Macro Run Plg Window 7
cHHE A sahideihh t BRI ECEDIQEDNNEIEBa Y

= gait2352_PiG osim |

1 < version="1.0" encoding="UTF-8" 2>
[H<OpenSimDocument Version="30000">
3708

Click [+] to expand and navigate file, section by section

Notepad++ provides alternative to GUI for:
= getting information about model components

= editing models
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Viewing model files in Notepad++

» Forexample, expand:

<Model, then <BodySet, then <objects, then <Body name="femur_r"

~
[f CA\Users\asarnold\Desktop\GCMAS tutorial\Apoarva's TutorialFiles\gait2392_PiG.osim - Notepad++ il 0
File Edit Search View Encoding Language Settings Macre Run  Plugins  Window 7 X

EHBRGE 4Dkl oe| il s BE EEAEED P E Eg Y

= gait2392_PiG .osim |

<BodySet> -
<objects>
<Body name="ground">

WO
(HHHHTHT]

<Body name="pelvis">

-

34T = <Body name="femur r"> —

348 <mass»9.3014</mass> . . .

349 <mass_center> 0 -0.17 0</mass_center> mass & inertial propertles

350 <inertia xx>0.1339</inertia xx>

351 <inertia_ yy>0.0351</inertia_yv>

352 <inertia zz»>0.1412</inertia_zz>

353 <inertia xy>0</inertia xy> E

354 <inertia xz>0</inertia xz>

355 <inertia yz>0</inertia vz>

356 <!——Joint that connects this body with the parent body.-->

357 [ <

258 H <CustomJoint name

s0s | < I £

510 = <VisibleCbject>

511 <!--5et of geometry files and associated attributes, allow .¥kR, -3kl, -ghi-——>

512 <GeometrySet>

=1LE <objects>

514 = <DisplayGeometry>

2D <!--Name of i >

516 <gecmetry_fife>femur.ytp</de

517 <!--Color used he geometry when visible-->

518 <color> 1 1 1</color>

ST <!--Name of texture file .jpg, .hmp—->

520 <texture_file />

521 <!--in body transform specified a= 3 rotations (rad) followed by 3 translations rX r¥ rZ [x L¥ Rz-—>

522 <transform> -0 0 -0 0 0 O</transform>

=EE <!—-Three scale factors for display purposes: scaleX scaleY scaleZ-->

S <scale_factors> 1 1 1</scale_ factors>

G <!—-Display Pref. 0:Hide 1:Wire 3:Flat 4:5haded-->

526 <display_preference>4<fdisplay_preference> -
[

I »
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Viewing model files in Notepad++

» <ForceSet provides information about muscle properties

E{ Ch\Users\asarnold\Desktop\GCMAS tutorial\Apoorva's TutorialFiles\gait2392_PiG.osim - Notepad++

File Edit Search View Encoding Language Settings

= gait2392_PiG osim |

Macro  Run

Plugins  Window 7

cEHEEGEl & Bkl et s BE

=1

EE| G EE Y

<ForceSet>
b <objects>
<Thelen2003Muscle name="glut medl r">
<Thelen2003Muscle name="glut med2 r">
<Thelen2003Muscle name="glut med3 r">
<Thelen2003Muscle name="glut minl r">
<Thelen2003Muscle name="glut minZ r">
<Thelen2003Muscle name="glut min3 r"> E
<Thelen2003Muscle name="semimem r">
<!--Flag indicating whether the force is disabled or not. Disabled means that the force is not active in subsequent dynamics ¢
<isDisabled>false</isDisabled>
<!——Minimam allowed wvalue for control signal. Used primarily when solwving for control wvalues.-—-—>
<min_control>D</min_controls>
<!——Maximum allowed wvalue for control signal. Used primarily when solwving for control wvalues.-->
<max_control>l</max_controls>
<1--The set of points defining the path of the muscle.--3>
<GeometryPath>
<! --The maximum force this actuator can produce.-->
<nptimal_fnrce)l(;"optimal_force}
<!—-Maximum isometric force that the fibers can generate-->
2 <max_isometric force>1288</max isometric_force> t th t
2 <!--Cptimal length of the muscle fihers—-> parame ers a
27 <optimal fiber length>0.08</optimal fiber length>
27 <!--Resting length of the tendon--> - Scale F-L-V CUrves
2 <tendon_slack length>0.359</tendon_slack length>
2 <!--Angle between tendon and fibers at optimal fiber length expressed in radians-->
2 <pennation_angle_ at_optimal>0.26179939</pennation angle_at_optimal>
27 <!-—-Maximum contraction wvelocity of the fihers, in optimal fiberlengths/second-->
27 <max contraction velocity>10</max contraction velocity>
27 <!——time constant for ramping up muascle activation—->
2 <activation time constant>0.01</activation time constant>
2 <!——time constant for ramping down of muscle activation-->
2 <deactivation_time constant>0.04</deactivation time constant>
27 <!--tendon strain at maxXimum isometric muscle force--»
4 1 ] 3
eXtensible Markup Language file length : 493245  lines: 9708 Ln:515 Col:13 Sel:0|0 Dos\Windows UTF-8 w/o BOM INS
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